This article describes how to configure a point to point PPPoE connection between two Cisco routers.
This article is a part of my article collection: Cisco configuration snippets. The snippets show just and only just how to do a basic configuration on a specific topic.
Server side
!
username myuser password 0 cisco
!
!
bba-group pppoe global
virtual-template 1
!
!
!
interface FastEthernet0/0
no shutdown
no ip address
duplex full
!
!
interface Virtual-Template1
mtu 1492
ip address 10.0.0.1 255.255.255.0
peer default ip address pool clientpool
ppp authentication pap chap
!
!
ip local pool clientpool 10.0.0.10 10.0.0.200
The MTU is lowered to 1492 due to PPP header taking up 8 biytes
Client side
!
username ISP password 0 cisco
!
!
interface FastEthernet0/0
no ip address
duplex full
pppoe enable group global
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname myuser
ppp chap password 0 cisco
!
asdfasdf